CVE-2020-11023: JQuery Cross-Site Scripting (XSS) Vulnerability

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery’s DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Description quoted from the CVE record (assigned by GitHub_M, published 2020-04-29).

Weakness: CWE-79: Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’)

How it can be exploited

Exploitable over the network with high attack complexity needing no privileges and a user must take an action. Impact: confidentiality high, integrity low, availability none. CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N

CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: no. Technical impact: partial.

On CISA KEV since
2025-01-23
US federal deadline
2025-02-13
Ransomware use
Not known

Public exploit evidence (Exploit Observer)

Also known as: BDU:2020-04949, CNNVD-202004-2420, CNVD-2020-27491, EDB-49767, EUVD-2020-0387, EUVD-2023-1659, GHSA-cqcc-mm6x-vmvw, GHSA-jpcq-cgw6-v4j6, SNYK-JS-JQUERY-565129, SNYK-JS-SEQUELIZEORM-6044694, SNYK-ORACLE8-GCCTOOLSET13LIBUBSANDEVEL-8728620, SNYK-PYTHON-SPHINX-570773

VEDAS cluster: VEDAS:ABSTRACTARGO

Exploit Observer links 8 pieces of public exploit code or detection modules that name this CVE or one of its aliases.

Exploit code and modules (8)

Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.

Research and write-ups (9)

Vulnerability databases and vendor advisories (20)

Catalogue entries, not exploit evidence.

474 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.849
very likely to be attacked soon
VEDAS
0.980
strong exploit evidence
On CISA KEV
Yes, since 2025-01-23
Detection rule
None yet
EPSS (chance of attack)
10No cve-scores data 2026-02-22 to 2026-08-08no data0.1CVE-2020-11023 EPSS over time2025-042026-11-01
VEDAS (exploit evidence)
10No cve-scores data 2026-02-22 to 2026-08-08no data0.9CVE-2020-11023 VEDAS over time2025-042026-11-01

Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish.

Who is affected

ProductAffectedNot affected
jquery jQueryversion >= 1.0.3, < 3.5.0Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: jquery jquery, the_jquery_foundation jquery, ао_«концерн_вниинс» ос_он_«стрелец», ао_«нтц_ит_роса» роса_кобальт, ооо_«нцпр» мсвсфера, ооо_«ред_софт» ред_ос.

How to fix it

CISA required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Vendor guidance:

1 more

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

References

Vendor advisories and patches

Government sources

Other references

45 more

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.