CVE-2024-52012: Apache Solr: Configset upload on Windows allows arbitrary path write-access
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-04 15:41 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Relative Path Traversal vulnerability in Apache Solr. Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the “configset upload” API. Commonly known as a “zipslip”, maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem. This issue affects Apache Solr: from 6.6 through 9.7.0. Users are recommended to upgrade to version 9.8.0, which fixes the issue. Users unable to upgrade may also safely prevent the issue by using Solr’s “Rule-Based Authentication Plugin” to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.
Description quoted from the CVE record (assigned by apache, published 2025-01-27).
Weakness: CWE-23 Relative Path Traversal
How it can be exploited
Exploitable over the network with low attack complexity needing low privileges and no user interaction. Impact: confidentiality low, integrity low, availability none. CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: partial.
Public exploit evidence (Exploit Observer)
Exploit Observer found 1 research write-up naming this CVE.
See all 7 references on Exploit Observer
Live scores
- EPSS
- 0.471
likely to be attacked soon - VEDAS
- 0.949
strong exploit evidence - On CISA KEV
- Not listed
- Detection rule
- No public rule yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| Apache Software Foundation Apache Solr | from 6.6 up to and including 9.7.0 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
How to fix it
Vendor guidance:
- https://lists.apache.org/thread/yp39pgbv4vf1746pf5yblz84lv30vfxd (vendor-advisory)
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
References
Vendor advisories and patches
- https://lists.apache.org/thread/yp39pgbv4vf1746pf5yblz84lv30vfxd (vendor-advisory)
Other references
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.