CVE-2025-23209: Craft CMS Code Injection Vulnerability
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.
Description quoted from the CVE record (assigned by GitHub_M, published 2025-01-18).
Weakness: CWE-94: Improper Control of Generation of Code (‘Code Injection’)
How it can be exploited
Exploitable over the network with high attack complexity needing low privileges and a user must take an action. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: no. Technical impact: total.
- On CISA KEV since
- 2025-02-20
- US federal deadline
- 2025-03-13
- Ransomware use
- Not known
Public exploit evidence (Exploit Observer)
Also known as: CNNVD-202501-2703, EUVD-2025-0208, EUVD-2025-24040, GHSA-2vcf-qxv3-2mgw, GHSA-x684-96hh-833x, SNYK-PHP-CRAFTCMSCMS-8656566
VEDAS cluster: VEDAS:CHARTLANTERN
Exploit Observer has no public exploit code that names this CVE or one of its aliases.
Vulnerability databases and vendor advisories (11)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2025-0208
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2025-24040
- Vulnerability database or vendor advisory: https://github.com/advisories/GHSA-2vcf-qxv3-2mgw
- Vulnerability database or vendor advisory: https://github.com/advisories/GHSA-x684-96hh-833x
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2025-23209
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/CVE-2025-23209
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/GHSA-x684-96hh-833x
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/GHSA-x684-96hh-833x
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-PHP-CRAFTCMSCMS-8656566
- Vulnerability database or vendor advisory: https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209
- Vulnerability database or vendor advisory: https://www.cnnvd.org.cn/home/globalSearch?keyword=CNNVD-202501-2703
102 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.216
likely to be attacked soon - VEDAS
- 0.980
strong exploit evidence - On CISA KEV
- Yes, since 2025-02-20
- Detection rule
- None yet
Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish.
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| craftcms cms | version >= 5.0.0-RC1, < 5.5.5 version >= 4.0.0-RC1, < 4.13.8 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: craftcms craft_cms.
How to fix it
CISA required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Vendor guidance:
- https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x
- https://nvd.nist.gov/vuln/detail/CVE-2025-23209
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
References
Government sources
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209 (government-resource)
Other references
- https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x (x_refsource_CONFIRM)
- https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603 (x_refsource_MISC)
- https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret (x_refsource_MISC)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.