CVE-2026-105863: Payload authentication token field handling issue
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-04 15:41 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Payload is a free and open source headless content management system. In versions after 3.0.0 and before 3.90.0, a custom field option that maps a field to a reserved authentication claim name can place unintended values in the authentication token issued at login. This issue is fixed in version 3.90.0.
Description quoted from the CVE record (assigned by GitHub_M, published 2026-10-06).
Weakness: CWE-290: Authentication Bypass by Spoofing; CWE-915: Improperly Controlled Modification of Dynamically-Determined Object Attributes
How it can be exploited
Exploitable over the network with low attack complexity only when specific conditions are present needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: yes. Technical impact: total.
Public exploit evidence (Exploit Observer)
Exploit Observer found 1 code repository naming this CVE.
Code repositories that name a CVE are often scanners, copies or fakes, and some are malware. Read the code before running anything.
See all 6 references on Exploit Observer
Live scores
- EPSS
- 0.004
low predicted chance of attack - VEDAS
- 0.966
strong exploit evidence - On CISA KEV
- Not listed
- Detection rule
- No public rule yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| payloadcms payload | version >= 3.0.0, < 3.90.0 version >= 4.0.0-canary.0, < 4.0.0-canary.34 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
How to fix it
No fixed version or vendor advisory is listed in the CVE record yet. Watch the vendor’s security page.
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
References
Other references
- https://github.com/payloadcms/payload/security/advisories/GHSA-66wr-7vmr-p5jq (x_refsource_CONFIRM)
- https://github.com/payloadcms/payload/commit/56cd5cd050a57daebf33159e41e5ff9d4a45239c (x_refsource_MISC)
- https://github.com/payloadcms/payload/releases/tag/v3.90.0 (x_refsource_MISC)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.