CVE-2026-109518: APT RCE via hard link reuse

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-04 15:41 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges. The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration

Description quoted from the CVE record (assigned by canonical, published 2026-11-04).

Weakness: CWE-62 UNIX hard link; CWE-367 Time-of-check time-of-use (TOCTOU) race condition

How it can be exploited

Exploitable over the network with low attack complexity only when specific conditions are present needing no privileges and a user must take an action. Impact: confidentiality high, integrity high, availability high. CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: total.

Public exploit evidence (Exploit Observer)

Exploit Observer has no public exploit code naming this CVE. Check Exploit Observer for anything new.

Live scores

EPSS
0.000
low predicted chance of attack
VEDAS
0.049
little exploit evidence
On CISA KEV
Not listed
Detection rule
None yet

Who is affected

ProductAffectedNot affected
Debian APT (apt)before 1.2.36
from 1.4.0 before 1.4.12
from 1.6.0 before 1.6.19
from 1.8.0 before 1.8.2.4
from 1.8.3 up to and including 1.8.5
from 2.0.0 before 2.0.12
from 2.2.0 before 2.2.5
from 2.4.0 before 2.4.15
and 5 more ranges
Not stated
Ubuntu APT (apt)before 1.0.1ubuntu2.24+esm4
from 1.2.0 before 1.2.36+esm1
from 1.6.0 before 1.6.19+esm1
from 2.0.0 before 2.0.12+esm1
from 2.4.0 before 2.4.15ubuntu0.1
from 2.8.0 before 2.8.4ubuntu0.1
from 3.2.0 before 3.2.1ubuntu0.1
from 3.3.0 before 3.3.3ubuntu0.1
Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

How to fix it

Fixed versions stated in the CVE record: 1.2.36, 1.4.12, 1.6.19, 1.8.2.4, 2.0.12, 2.2.5, 2.4.15, 2.6.2, 2.8.4, 3.0.4, 3.2.1, 3.3.6 and others.

Vendor guidance:

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

Advisories on this CVE

References

Vendor advisories and patches

Other references

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.

Supporting partners

Feasible SecurityAskealGoTrust