CVE-2026-22708: Cursor has a Terminal Tool Allowlist Bypass via Environment Variables
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Cursor is a code editor built for programming with AI. Prior to 2.3, hen the Cursor Agent is running in Auto-Run Mode with Allowlist mode enabled, certain shell built-ins can still be executed without appearing in the allowlist and without requiring user approval. This allows an attacker via indirect or direct prompt injection to poison the shell environment by setting, modifying, or removing environment variables that influence trusted commands. This vulnerability is fixed in 2.3.
Description quoted from the CVE record (assigned by GitHub_M, published 2026-01-14).
Weakness: CWE-15: External Control of System or Configuration Setting; CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component (‘Injection’); CWE-77: Improper Neutralization of Special Elements used in a Command (‘Command Injection’); CWE-78: Improper Neutralization of Special Elements used in an OS Command (‘OS Command Injection’); CWE-94: Improper Control of Generation of Code (‘Code Injection’); CWE-269: Improper Privilege Management
How it can be exploited
Exploitable over the network with high attack complexity only when specific conditions are present needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: total.
Public exploit evidence (Exploit Observer)
Also known as: CNNVD-202601-2388, EUVD-2026-2678
Exploit Observer has no public exploit code that names this CVE or one of its aliases.
Vulnerability databases and vendor advisories (3)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2026-2678
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2026-22708
- Vulnerability database or vendor advisory: https://www.cnnvd.org.cn/home/globalSearch?keyword=CNNVD-202601-2388
2 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.008
low predicted chance of attack - VEDAS
- 0.053
little exploit evidence - On CISA KEV
- Not listed
- Detection rule
- None yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| cursor cursor | version < 2.3 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: anysphere cursor.
How to fix it
No fixed version or vendor advisory is listed in the CVE record yet. Watch the vendor’s security page.
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
Advisories on this CVE
- Cursor 2026 CVEs (2 Apr 2026)
References
Other references
- https://github.com/cursor/cursor/security/advisories/GHSA-82wg-qcm4-fp2w (x_refsource_CONFIRM)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.