CVE-2026-3784: wrong proxy connection reuse with credentials

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-04 15:41 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

curl would wrongly reuse an existing HTTP proxy connection doing CONNECT to a server, even if the new request uses different credentials for the HTTP proxy. The proper behavior is to create or use a separate connection.

Description quoted from the CVE record (assigned by curl, published 2026-03-11).

Weakness: Authentication Bypass by Primary Weakness; CWE-305 Authentication Bypass by Primary Weakness

How it can be exploited

Exploitable over the network with low attack complexity needing no privileges and no user interaction. Impact: confidentiality low, integrity low, availability none. CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: yes. Technical impact: partial.

Public exploit evidence (Exploit Observer)

Exploit Observer found 2 research write-ups naming this CVE.

See all 15 references on Exploit Observer

Live scores

EPSS
0.004
low predicted chance of attack
VEDAS
0.838
likely exploited
On CISA KEV
Not listed
Detection rule
No public rule yet

Who is affected

ProductAffectedNot affected
curlfrom 7.7.0 before 8.14.2
from 8.15.0 before 8.16.1
from 8.17.0 before 8.19.0
Not stated
curlfrom a1d6ad26100b before 5f13a7645e56 (git commit)Not stated
curlversion 8.18.0
version 8.17.0
version 8.16.0
version 8.15.0
version 8.14.1
version 8.14.0
version 8.13.0
version 8.12.1
and 183 more ranges
Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

How to fix it

Fixed versions stated in the CVE record: 8.14.2, 8.16.1, 8.19.0.

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

References

Other references

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.

Supporting partners

Feasible SecurityAskealGoTrust