CVE-2026-42533: NGINX Map directive and Regex matching vulnerability

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and a string expression references the map’s regex capture variables before referencing the map output variable. Alternatively, the same result could be achieved by using a non-cacheable variable in a string expression under certain conditions. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or to possibly trigger a code execution. There is no control plane exposure; this is a data plane issue only.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Description quoted from the CVE record (assigned by f5, published 2026-07-15).

Weakness: CWE-122 Heap-based Buffer Overflow

How it can be exploited

Exploitable over the network with high attack complexity with no special attack requirements needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

CISA assessment (SSVC): CISA assesses that a public proof of concept exists. Automatable: no. Technical impact: total.

Public exploit evidence (Exploit Observer)

Also known as: BDU:2026-09927, EUVD-2026-44683, GHSA-fxfg-v4rj-hp95

VEDAS cluster: VEDAS:GAUNTLETMIASMA

Exploit Observer links 11 pieces of public exploit code or detection modules that name this CVE or one of its aliases.

Exploit code and modules (11)

Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.

Research and write-ups (1)

Vulnerability databases and vendor advisories (13)

Catalogue entries, not exploit evidence.

61 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.063
some chance of attack soon
VEDAS
0.926
strong exploit evidence
On CISA KEV
Not listed
Detection rule
None yet

Who is affected

ProductAffectedNot affected
F5 NGINX Plusfrom 37.0.0.1 before 37.0.3.1
from R36 before R36 P7
from R33 before *
Not stated
F5 NGINX Open Sourcefrom 1.31.2 before 1.31.3
from 0.9.6 before 1.30.4
Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: f5 nginx_gateway_fabric, f5 nginx_ingress_controller, f5 nginx_plus, f5 waf, nginx_inc. nginx_open_source, nginx_inc. nginx_plus, ооо_«ред_софт» ред_ос.

How to fix it

Fixed versions stated in the CVE record: 37.0.3.1, R36 P7, 1.31.3, 1.30.4.

Vendor guidance:

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

References

Vendor advisories and patches

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.