CVE-2026-48172: LiteSpeed cPanel Plugin Privilege Escalation Vulnerability
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE “cpanel_jsonapi_func=redisAble” /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7.
Description quoted from the CVE record (assigned by mitre, published 2026-05-21).
Weakness: CWE-266 Incorrect Privilege Assignment
How it can be exploited
Exploitable over the network with low attack complexity with no special attack requirements needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: yes. Technical impact: total.
- On CISA KEV since
- 2026-05-26
- US federal deadline
- 2026-05-29
- Ransomware use
- Not known
Public exploit evidence (Exploit Observer)
Also known as: EUVD-2026-31204, GHSA-fxrh-cwjh-m33v
Exploit Observer links 2 pieces of public exploit code or detection modules that name this CVE or one of its aliases.
Exploit code and modules (2)
Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.
- Code repository: https://github.com/fevar54/cve-2026-48172---litespeed-cpanel-plugin-version-auditor
- Code repository: https://github.com/retmakarunia/cve-2026-48172
Vulnerability databases and vendor advisories (4)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2026-31204
- Vulnerability database or vendor advisory: https://github.com/advisories/GHSA-fxrh-cwjh-m33v
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2026-48172
- Vulnerability database or vendor advisory: https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-48172
4 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.179
likely to be attacked soon - VEDAS
- 0.547
some exploit evidence - On CISA KEV
- Yes, since 2026-05-26
- Detection rule
- None yet
Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish.
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| LiteSpeed Technologies cPanel Plugin (WHM Plugin/cPanel Plugin) | from 2.3 before 2.4.7 | Not stated |
| LiteSpeed Technologies WHM Plugin (WHM Plugin/cPanel Plugin) | before 5.3.1.0 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: litespeedtech litespeed_cpanel_plugin, litespeedtech litespeed_whm_plugin.
How to fix it
Fixed versions stated in the CVE record: 2.4.7, 5.3.1.0.
CISA required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Vendor guidance:
- https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/
- https://nvd.nist.gov/vuln/detail/CVE-2026-48172
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
References
Government sources
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-48172 (government-resource)
Other references
- https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/cpanel
- https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/release-log
- https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.