CVE-2026-63030: WordPress Core Interpretation Conflict Vulnerability

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.

Description quoted from the CVE record (assigned by WPScan, published 2026-07-17).

Weakness: CWE-436 Interpretation Conflict

How it can be exploited

Exploitable over the network with low attack complexity needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: yes. Technical impact: total.

On CISA KEV since
2026-07-21
US federal deadline
2026-07-24
Ransomware use
Not known

Public exploit evidence (Exploit Observer)

Also known as: BDU:2026-10241, EUVD-2026-45280

VEDAS cluster: VEDAS:BARLEYBOOST

Exploit Observer links 55 pieces of public exploit code or detection modules that name this CVE or one of its aliases.

Exploit code and modules (55)

Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.

Research and write-ups (12)

Vulnerability databases and vendor advisories (5)

Catalogue entries, not exploit evidence.

265 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.106
likely to be attacked soon
VEDAS
0.978
strong exploit evidence
On CISA KEV
Yes, since 2026-07-21
Detection rule
Nuclei · Suricata
EPSS (chance of attack)
100.1CVE-2026-63030 EPSS over time2026-082026-11-01
VEDAS (exploit evidence)
100.9CVE-2026-63030 VEDAS over time2026-082026-11-01

Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish.

Who is affected

ProductAffectedNot affected
WordPress WordPressfrom 6.9.0 before 6.9.5
from 7.0.0 before 7.0.2
Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: wordpress wordpress, wordpress_foundation wordpress.

How to fix it

Fixed versions stated in the CVE record: 6.9.5, 7.0.2.

CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset’s internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Vendor guidance:

How to detect it

Nuclei template (active check)

WordPress - Authentication Bypass

WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.

Name and description quoted from the template, written by VEDAS.

The template sends 2 requests (POST /?rest_route=/batch/v1, GET /); it decides using dsl, status, word matchers. Severity in the template: critical. Marked as not yet verified against a live vulnerable target.

Run it against a host you own or are authorised to test:

bash
nuclei -u https://your-host -t CVE-2026-63030.yaml
Show the template (62 lines)
yaml
id: CVE-2026-63030

info:
  name: WordPress - Authentication Bypass
  author: vedas-arpsyndicate
  severity: critical
  description: |
    WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion
    issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker
    to perform SQL Injection and achieve Remote Code Execution.
  reference:
    - https://www.exploit.observer/?keyword=CVE-2026-63030&match=exact
    - https://subdomain.center/?engine=ammonites&keyword=wordpress&match=exact
  classification:
    cvss-metrics: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
    cvss-score: 9.8
    cve-id: CVE-2026-63030
    cwe-id: CWE-287
  metadata:
    verified: false
  tags: cve,cve2026,wordpress,wp-core,preauth,batch-api,route-confusion,vkev,kev
flow: http(1) && http(2)

http:
  # Step 1: Confirm the target is a WordPress site before probing the batch endpoint
  - method: GET
    path:
      - "{{BaseURL}}"

    matchers:
      - type: dsl
        dsl:
          - 'contains(body, "wp-content") || contains(body, "wp-includes") || contains(tolower(header), "rest_route") || contains(tolower(header), "wp-json")'
        internal: true

  # Step 2: Safe route-confusion detection (no SQL execution, no timing oracle)
  - raw:
      - |
        POST /?rest_route=/batch/v1 HTTP/1.1
        Host: {{Hostname}}
        Content-Type: application/json

        {"requests":[{"method":"POST","path":"///"},{"method":"POST","path":"/wp/v2/posts"},{"method":"POST","path":"/wp/v2/block-renderer/core/archives"},{"method":"POST","path":"/batch/v1","body":{"requests":[]}}]}

    matchers-condition: and
    matchers:
      - type: word
        part: body
        words:
          - "parse_path_failed"
          - "block_cannot_read"
          - "rest_batch_not_allowed"
        condition: and

      - type: word
        part: content_type
        words:
          - "application/json"

      - type: status
        status:
          - 207

CVE-2026-63030.yaml on GitHub

Suricata rules (network detection)

1 rule that alert on traffic matching this exploit: VEDAS CVE-2026-63030 WordPress - Authentication Bypass. Add them to your Suricata rule set and reload.

Show the rules
suricata
alert http $EXTERNAL_NET any -> $HTTP_SERVERS $HTTP_PORTS (msg:"VEDAS CVE-2026-63030 WordPress - Authentication Bypass"; flow:established,to_server; http.request_body; content:"{requests:[{method:POST,path:///},{method:POST,path:/wp/v2/p"; nocase; fast_pattern; classtype:web-application-attack; reference:cve,CVE-2026-63030; reference:url,https://www.exploit.observer/?keyword=CVE-2026-63030&match=exact; reference:url,https://subdomain.center/?engine=ammonites&keyword=wordpress&match=exact; sid:1011630; rev:1;)

CVE-2026-63030.rules on GitHub

References

Vendor advisories and patches

Exploits and technical analysis

Government sources

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer, vedas-signatures. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.