CVE-2026-88804: Unauthenticated update of public UI settings leading to stored cross-site scripting in Rancher
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-04 15:41 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
An unauthenticated update of public UI settings could be used by remote attackers to execute a stored cross-site scripting attack in the Rancher UI, in SUSE Rancher 2.15 before 2.15.2, 2.14 before 2.14.6, 2.13 before 2.13.10, 2.12 before 2.12.14 and 2.11 before 2.11.18.
Description quoted from the CVE record (assigned by suse, published 2026-09-28).
Weakness: CWE-79 Improper neutralization of input during web page generation (‘cross-site scripting’)
How it can be exploited
Exploitable over the network with low attack complexity needing no privileges and a user must take an action. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: total.
Public exploit evidence (Exploit Observer)
Exploit Observer found 1 Nuclei template and 1 code repository naming this CVE.
Code repositories that name a CVE are often scanners, copies or fakes, and some are malware. Read the code before running anything.
See all 4 references on Exploit Observer
Live scores
- EPSS
- 0.010
some chance of attack soon - VEDAS
- 0.985
strong exploit evidence - On CISA KEV
- Not listed
- Detection rule
- No public rule yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| SUSE Rancher | from 2.15.0 before 2.15.2 from 2.14.0 before 2.14.6 from 2.13.0 before 2.13.10 from 2.12.0 before 2.12.14 from 2.11.0se before 2.11.18 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
How to fix it
Fixed versions stated in the CVE record: 2.15.2, 2.14.6, 2.13.10, 2.12.14, 2.11.18.
Vendor guidance:
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
References
Vendor advisories and patches
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.